NOTICE!

Switch to a compatible browser before October 7 for continued access to the E-Bill Express service

IMPORTANT MESSAGE

To avoid an interruption in E-Bill Express service, you may have to switch to a browser that supports Transport Layer Security (TLS) 1.2 before October 7, 2017.

 

What you need to do before October 7

  • For continued access to the E-Bill Express service, if you are currently using browsers that do not support TLS 1.2 (such as Internet Explorer (IE) 8, 9, and 10), you must upgrade to one of the following recommended browsers:

    • Chrome
    • Edge
    • Firefox
    • IE 11

  • Users who don’t use a compatible browser by the deadline will receive an error message upon trying to sign on to the service. As soon as you begin using a compatible browser, you’ll be able to access the service as usual.

    • After October 7, they will be unable to access the service to pay bills if their browser does not support TLS 1.2.

 

If you are already using a browser that supports TLS 1.2, please disregard this message.